Fix commands.tex rule and add cleaning rule.
[doldaconnect.git] / doc / protocol / Makefile.am
index 40f8599..3637059 100644 (file)
@@ -10,10 +10,14 @@ protocol.1st: protocol.tex commands.tex
        latex protocol
        touch protocol.1st
 
-commands.tex: cmds/*.tex
-       rm -f commands.tex \
-       for f in cmds/*.tex; do \
+commands.tex: cmd/*.tex
+       rm -f commands.tex; \
+       for f in cmd/*.tex; do \
                echo "\\begin{reqspec}{${f%.tex}}" >>commands.tex; \
-               cat "$f" >>commands.tex; \
+               cat "$$f" >>commands.tex; \
                echo "\\end{reqspec}" >>commands.tex; \
        done
+
+clean-local:
+       rm -f protocol.aux protocol.log protocol.dvi commands.tex \
+       protocol.1st protocol.ps