Create portage overlay tree.
[icmp-dn.git] / admin / portage / net-misc / icmpdn / icmpdn-0.1.ebuild
CommitLineData
9aad29a1
DC
1inherit eutils
2
3DESCRIPTION="ICMP Domain Name utilities"
4HOMEPAGE="http://www.dolda2000.com/~fredrik/icmp-dn/"
5SRC_URI="http://www.dolda2000.com/~fredrik/icmp-dn/${P}.tar.gz"
6
7LICENSE="GPL-2"
8SLOT="0"
9KEYWORDS="x86"
10IUSE=""
11
12DEPEND=""
13
14src_unpack() {
15 unpack ${A}
16 cd ${S}
17}
18
19src_compile() {
71b7d521
DC
20 econf --sysconfdir=/etc \
21 --libdir=/etc || die "Configuration failed"
9aad29a1
DC
22 emake || die "Make failed"
23}
24
25src_install() {
26 make install DESTDIR=${D} || die "Install failed"
27 dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README
28}
29
30pkg_postinst() {
31 einfo
32 einfo "To use the ICMP nameswitch module, add \"icmp\""
33 einfo "to the \"hosts\" line in your /etc/nsswitch.conf"
34 einfo
35 ebeep 3
36}