Fix prefixes.
[icmp-dn.git] / admin / icmpdn-0.1.ebuild
1 inherit eutils
2
3 DESCRIPTION="ICMP Domain Name utilities"
4 HOMEPAGE="http://www.dolda2000.com/~fredrik/icmp-dn/"
5 SRC_URI="http://www.dolda2000.com/~fredrik/icmp-dn/${P}.tar.gz"
6
7 LICENSE="GPL-2"
8 SLOT="0"
9 KEYWORDS="x86"
10 IUSE=""
11
12 DEPEND=""
13
14 src_unpack() {
15     unpack ${A}
16     cd ${S}
17 }
18
19 src_compile() {
20     econf --sysconfdir=/etc \
21           --libdir=/etc || die "Configuration failed"
22     emake || die "Make failed"
23 }
24
25 src_install() {
26     make install DESTDIR=${D} || die "Install failed"
27     dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README
28 }
29
30 pkg_postinst() {
31     einfo
32     einfo "To use the ICMP nameswitch module, add \"icmp\""
33     einfo "to the \"hosts\" line in your /etc/nsswitch.conf"
34     einfo
35     ebeep 3
36 }