a2fb7b59d263ff154ca39c901322006ef9c1aa8c
[icmp-dn.git] / admin / icmpdn-0.1.ebuild
1 inherit eutils
2
3 DESCRIPTION="ICMP Domain Name utilities"
4 HOMEPAGE="http://www.dolda2000.com/~fredrik/icmp-dn/"
5 SRC_URI="http://www.dolda2000.com/~fredrik/icmp-dn/${P}.tar.gz"
6
7 LICENSE="GPL-2"
8 SLOT="0"
9 KEYWORDS="x86"
10 IUSE=""
11
12 DEPEND=""
13
14 src_unpack() {
15     unpack ${A}
16     cd ${S}
17 }
18
19 src_compile() {
20     econf || die "Configuration failed"
21     emake || die "Make failed"
22 }
23
24 src_install() {
25     make install DESTDIR=${D} || die "Install failed"
26     dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README
27 }
28
29 pkg_postinst() {
30     einfo
31     einfo "To use the ICMP nameswitch module, add \"icmp\""
32     einfo "to the \"hosts\" line in your /etc/nsswitch.conf"
33     einfo
34     ebeep 3
35 }