Stupid typo...
[icmp-dn.git] / admin / portage / net-misc / icmpdn / icmpdn-0.1.ebuild
1 # Copyright 2005 Fredrik Tolf <fredrik@dolda2000.com>
2 # Distributed under the terms of the GNU General Public License v2
3
4 inherit eutils
5
6 DESCRIPTION="ICMP Domain Name utilities"
7 HOMEPAGE="http://www.dolda2000.com/~fredrik/icmp-dn/"
8 SRC_URI="http://www.dolda2000.com/~fredrik/icmp-dn/${P}.tar.gz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="x86"
13 IUSE=""
14
15 DEPEND=""
16
17 src_unpack() {
18     unpack ${A}
19     cd ${S}
20 }
21
22 src_compile() {
23     econf --sysconfdir=/etc \
24           --libdir=/lib || die "Configuration failed"
25     emake || die "Make failed"
26 }
27
28 src_install() {
29     make install DESTDIR=${D} || die "Install failed"
30     fperms 4755 /usr/bin/idnlookup
31     doinitd ${FILESDIR}/${PN}.init ${PN}
32     dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README
33 }
34
35 pkg_postinst() {
36     einfo
37     einfo "To use the ICMP nameswitch module, add \"icmp\""
38     einfo "to the \"hosts\" line in your /etc/nsswitch.conf"
39     einfo
40     ebeep 3
41 }